投稿 资料上传 提问 搜索
您现在的位置是: 首页 > 问答 > 正文

关于centos6 yum本地rpm包的python依赖问题!

使用yum localinstall 安装公司的本地rpm包命令运行报错

error:Package: my-package.el7.x86_64 (/my-package.el7.x86_64)
Requires: Python >= 2.7.13

1.自己安装了2.7.13版本的python 并设置成了默认。(此时yum的解释器依然是python2.6不然会报错) 

Python 2.7.13 (default, Mar 22 2020, 22:04:54) 
[GCC 4.4.7 20120313 (Red Hat 4.4.7-23)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>>

从新执行yum localinstall 后依然报错原有错误。

2.在网上下载了python2.7.13的rpm包

python27-python-2.7.13-3.el7.x86_64.rpm

在yum时同时安装两个包但依然报原有错  

 

问题回复
  1. 落影斑驳
    落影斑驳IT技术之家

    python27-python-2.7.13-3.el7.x86_64.rpm
    那个el7指的是版本7吧,你6.5的系统能安装吗?  

    回复